WP Google Maps

Опис

Найпростіше використовувати плагін Google Maps! Додайте індивідуальну карту Google до своїх публікацій та / або сторінок WordPress швидко і легко за допомогою наведеного короткого коду. Немає суєти Немає iFrames і супер простий у використанні! Ідеально підходить для карток контактів, маршрутів, карт із областями доставки та будь-яким іншим використанням, про яке ви можете думати!

Незважаючи на те, що безкоштовна версія WP Google Maps дозволяє створити карту Google із максимально допустимими маркерів, версія Pro дозволяє вам зробити це набагато більше!

WP Google Maps Pro Pro дозволяє створювати власні карти Google із маркуваннями високої якості, що містять розташування, описи, зображення, категорії, посилання та напрямки.

Lite версія (безкоштовно)

  • Найпопулярніший плагін для Карт Google на WordPress
  • Супер проста у використанні, не вимагає кодування!
  • Створіть стільки маркерів карти, скільки вам потрібно, просто введіть адресу
  • Відповідні карти
  • Відредагуйте свої маркери карти одним натисканням кнопки
  • 9 популярних тем на карті на вибір
  • Створіть або додайте власну тему карти
  • Перетягніть маркери карти до точного місцезнаходження
  • Add a map block to your page
  • Карти Google Streetview підтримуються
  • Підтримка символів UTF-8
  • Функція віджета карти
  • Функціональність карти на весь екран
  • Підтримка локалізації
  • Виберіть один із чотирьох типів карт Google: дорожня карта, місцевість, супутник та гібрид
  • Визначте власну ширину, висоту та масштабування для своєї карти
  • Додайте анімацію до маркерів карти!
  • Магазин функціональності локатора
  • Обмежити пошук локатора магазинів по країні
  • Додайте багатокутники до своєї карти
  • Додати полілінії / маршрути на карту
  • Створіть карту менше ніж за 30 секунд!
  • Клацніть правою кнопкою миші, щоб додати маркер до вашої карти
  • Немає реклами або посилань
  • Автозаповнення Карт Google
  • Транспортний шар Google Maps
  • Встановіть максимальний рівень масштабування для вашої карти
  • Подавати маркер на карті через вашу базу даних або файл XML
  • Сумісність з плагінами кешування
  • Сумісність з Cloudfare
  • Останні API Карт Google
  • Останній API OpenLayers

Професійне видання

  • Створити кілька карт!
  • Дозвольте відвідувачам отримувати маршрути до своїх маркерів.
  • Додайте описи, посилання та зображення до маркерів карти.
  • Додайте категорії до маркерів карти
  • Маркери фільтрів за категоріями
  • Машуп кілька карт
  • Додайте різні піктограми маркера або власні значки, щоб зробити вашу карту дійсно виділеною!
  • Перерахуйте маркери на карту чотирма способами; основний список, основний стіл, карусель, розширений стіл
  • Дозволити відвідувачам використовувати місце розташування карти як початкову або кінцеву точку для вказівки
  • Виберіть між Карткою Інфо Індії та Карткою Карти Google
  • Експортуйте / імпортуйте маркери у файл CSV для швидкого редагування.
  • Посилання Fusion таблиці на ваші Карти Google
  • Покажіть місцезнаходження вашого відвідувача на Карті
  • Імпортуйте файли KML / KMZ на карту
  • Більш розширені параметри для магазину
  • Дозволити користувачам використовувати своє місце розташування карти для локатора магазину
  • Пошук локаторів за категоріями
  • Приховати всі маркери карти, доки пошуковий пошук локатора магазину не буде завершено
  • Перемістіть список маркерів у вікні карти
  • Кілька функцій віджетів карти
  • Додайте піктограми маркера для карт із сітківкою
  • WordPress Мережа дружня
  • Отримайте WP-версію Google Maps Professional Edition всього за 39,99 дол. США

Переклади

Отримайте безкоштовну копію версії WP Google Maps Pro в обмін на переклад нашого плагіна!

  • Англійська – за замовчуванням
  • Російська (Олександра Бондарева)
  • Німецька
  • Французька (Арно Томас)
  • Польський (Міхал Котновський)
  • Фінська (Johanna Joutti)
  • Голландська (Ян Вітер)
  • Іврит
  • Датська (Патрік Джепсен)
  • Італійська (Томмасо Морі та Масімо Брегані)
  • Хорватська
  • Грецький (Константінос Коукулакіс)
  • Румунська (Cosmin Stroe)
  • Іспанська (Кармело Віллегас Круз)
  • Португальська (Хосе Антоніо Рібейро)
  • Бразильський португальський (Роберто Коста)
  • Турецька (Suha Karalar)
  • Шведський (Мартін Сліпнер)
  • Болгар (Любомир Колев)
  • Індонезійська (Нено)
  • Литовська
  • Чехословацький^

^Мовний файл потрібно оновити

Демо-версії

WP Google Maps Lite

WP Google Maps Pro

Документація

Вирішення проблем

Скріншоти

  • Версія "Lite" WP для Google Maps.
  • "Pro" версія WP Google Maps.
  • Версія WP для Google Maps Pro: користувачі можуть отримувати вказівки до маркерів вашої карти
  • Версія WP для Google Maps Pro: додайте спеціальні маркери на карту Google
  • WP Версія Google Maps Lite: Загальна сторінка налаштувань
  • Версія WP Google Maps Pro: сторінка загальних налаштувань
  • Версія WP для Google Maps Pro: сторінка налаштувань InfoWindow
  • Версія WP для Google Maps Pro: Розширені варіанти карт Google.
  • Версія WP для Google Maps Pro: параметри списку маркерів карти
  • Версія WP Google Maps Pro: Експортуйте / імпортуйте маркери карти
  • Версія WP для Google Maps Pro: відмітна маркерна карта карусельної карти
  • WP Версія Google Maps Lite: Налаштування Store Locator
  • WP Версія Google Maps Lite: Магазин Locator Map
  • WP Версія Google Maps Lite: Віджет карти
  • Виберіть тему для вашої карти або виберіть тему з нашої тематичної бібліотеки

Встановлення

Перший користувач WP Google Maps

Дякуємо за вибір WP Google Maps! Щоб створити свою карту Google, просто активуйте плагін і натисніть "Карти" у лівій навігаційній панелі. Після завантаження сторінки WP на Карти Google встановіть параметри своєї карти (висота, ширина, тип карти, рівень масштабування тощо), а потім за допомогою миші перетягніть карту Google у потрібне місце та натисніть кнопку «Зберегти карту». Скопіюйте та вставте короткий код у свій пост або сторінку, і WP Google Maps автоматично створить карту на вашій сторінці, використовуючи вибрані вище налаштування.

Додавання першого маркера карти

Щоб додати маркер до своєї карти Google, перейдіть до карти нижче в розділі адміністратора та введіть адресу або місцеположення GPS у полі Адреса адреси. Натисніть "Додати маркер", і WP Google Maps додасть ваш маркер до зазначеної вами адреси.

Налаштування Google Maps Store Locator

Щоб скористатися функцією WP Google Maps Store Locator, просто натисніть вкладку "Store Locator" на сторінці створення карти та виберіть "Так"

Часті питання

Як отримати WP Google Maps Pro?

Просто відвідайте веб-сайт http://www.wpgmaps.com і закупівлі WP-версії Google Maps Professional Edition за 39,99 дол. США. Безкоштовні оновлення та підтримка включені назавжди.

Я встановив плагін, тепер що?

Після встановлення та активації посилання має з'явитися на лівій навігаційній панелі в розділі WP-ADMIN. Натисніть посилання "WP Google Maps" та дотримуйтесь інструкцій на екрані.

Як мені помістити карту Google на мою сторінку / публікацію?

Щоб показати свою власну карту Google на вашій сторінці чи публікації, просто скопіюйте надіслану короткий код та вставте його на свою сторінку чи публікацію. WP Google Maps автоматично налаштовує карту до параметрів, вибраних на сторінці редагування карти.

Як додати віджет карти до мого віджета?

Щоб додати свою карту до області віджетів, просто перейдіть до пункту «Відображення-> Віджети» та перетягніть віконця «WP Google Maps» на бічну панель. Потім відредагуйте віджет карти, щоб відобразити правильну карту.

Я хочу використовувати це, але у мене немає WordPress

Спробуйте Nifty Maps – всеосяжний Map Builder для всіх веб-сайтів

Відгуки

Great plugin, great support

I use this plugin, both in free and Pro versions, on many sites I manage and it works really fine!
And if some issues happens (nobody is perfect, but mostly is a matter to plugin to be updated!) the support is kind and effective.
I recently had the support of Trevor Anderson and it was patient and precious!

Simone Mazzucconi aka Drauth

Great plugin, really useful!

This is a really awesome plugin that got the job done! Many thanks!

As a side note, I love how the changelog shows priority level of each update. I wish all plugin makers did that!!

Great support

Trevor Anderson was really helpful and my issue got solved very quickly.
Thanks!

Great tool and Trevor provided excellent support!

The options in the pro version are comprehensive. Everything I could think of in one tool!

I had some problems at first (maps don’t want to render w/ 100% height on my site) but Trevor from support figured out the problem and provided the solution (use px for height) right away.

A+ support and tool,

Anthony

Прочитати всі 1 773 відгуки

Учасники та розробники

“WP Google Maps” is open source software. The following people have contributed to this plugin.

Учасники

“WP Google Maps” було перекладено на 11 локалізацій. Thank you to the translators for their contributions.

Перекладіть “WP Google Maps” на вашу мову.

Цікавитесь розробкою?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Журнал змін

7.10.50 :- 2018-12-10 :- Low priority

  • Added blank alt attribute to OpenLayers marker img element
  • Updated WP version supported to 5.0

7.10.49 :- 2018-12-05 :- Low priority

  • Improved Gutenberg integration (new buttons added)

7.10.48 :- 2018-12-03 :- Low priority

  • Added a check for wp.editor in Gutenberg JS module
  • Fixed InfoWindow not initialized before open called when using marker open by default setting
  • Fixed WPGMZA.OLMap returning zoom one level too far in (fixes map zooms in one level on save)

7.10.47 :- 2018-11-22 :- Low priority

  • Removed all redundant calls to getPlace
  • Places AutoCompletes now only request the “name” and “formatted_address” fields
  • Changed “Create an API key now” link

7.10.46 :- 2018-11-20 :- Medium priority

  • Fixed store locator circle and radius not displayed when no markers are present
  • Fixed browser compatibility code causing Gutenberg dependency failure
  • Google API version is now fixed at “Quarterly” (solves RetiredVersion notice)
  • Unified store locator circle and radius logic for both XML and DB marker pull
  • All PHP classes and methods now have documentation blocks
  • Server side documentation added in /docs/php
  • Client side documentation added in /docs/js

7.10.45 :- 2018-11-12 :- Medium priority

  • Fixed places autocomplete not initializing with modern store locator
  • Fixed conflict with Autoptimize with large amounts of data by bypassing CSS optimization where shortcode is present
  • Enter key now triggers search on modern store locator

7.10.44 :- 2018-11-05 :- Medium priority

  • Fixed Modern Store Locator Circle not working when Google Maps geometry library not loaded
  • Fixed legacy-map-edit-page.js not enqueued when Gold add-on activated (with Pro >= 7.10.30)
  • Fixed store locator circle color settings not respected in OpenLayers
  • Improved unresolved dependency report, now reports requirements

7.10.43 :- 2018-10-31 :- High priority

  • Покращено попередній виправлення безпеки

7.10.42 :- 2018-10-25 :- High priority

  • Закрита потенційна XSS-вразливість в PHP_SELF на сторінці редагування карти

7.10.41 :- 2018-10-24 :- Medium priority

  • Змінено виняток для повідомлення, коли відсутні залежності v8 (виправлення виникає з Pro <7.10.37 у режимі розробника).

7.10.40 :- 2018-10-17 :- Medium priority

  • Додано тимчасовий виправлення залежностей модуля Гутенберга, що перешкоджає завантаженню wpgmaps.js, коли в режимі розробника
  • Фіксоване інфільмоване вікно, яке не відкривається на сенсорному пристрої під час дії "наведення"

7.10.39 :- 2018-10-15 :- High priority

  • Виправлена ​​помилка JS, коли система Gutenberg не завантажена

7.10.38 :- 2018-10-15 :- Medium priority

  • Додано заводський клас
  • Додано доповнення DIVI сумісності
  • Додано нове константи назви таблиці
  • Модулі додані, щоб прокласти шлях інтеграції Гутенберга
  • Скоригований завантажувач сценаріїв для підтримки зовнішніх залежностей
  • Виправлено маршрути API на кінцевому косі рисла з деякими налаштуваннями
  • Виправлено wpgmza_basic_get_admin_path, що призводить до того, що обгортка URL-адреси не підтримується

7.10.37 :- 2018-09-27 :- Medium priority

  • Виправлено невизначену змінну на пристрої, що вимикає iOS
  • Виправлено маркер редагування за допомогою API REST, який не працює, коли API-маршрут має дві косу риси
  • Фіксована карта не відображається з певними версіями таблиць даних, де не використовується пакетна версія

7.10.36 :- 2018-09-25 :- Medium Priority

  • Виправлена ​​зміна в 7.10.35, що спричиняє проблеми з подією OLMarker, запобігаючи відкриття infowindow
  • Випав .gitignore, що спричиняло проблеми з розгортанням, тепер використовуючи .gitattributes, щоб ігнорувати зведені файли

7.10.35 :- 2018-09-20 :- Medium priority

  • Додано посилання на нову документацію щодо вирішення проблем API до діалогового вікна помилки Google Maps API
  • Виправлена ​​помилка виклику диспетчера маркерів після перетягування при використанні OpenLayers
  • Виправлено карту диспетчеризації кліків після перетягування при використанні OpenLayers
  • Фіксований редактор карт правої кнопки миші з'являється кілька разів
  • Зафіксований редактор карт правої кнопки миші маркер зникає після перетягування карти
  • Виправлено сучасний кола локаторів магазинів, що збиває деякі пристрої iOS, вимкнувши цю функцію на пристроях iOS
  • Виправлено налаштування обробки жестів, яке не дотримується, коли встановлено тему теми

7.10.34 :- 2018-09-17 :- Low priority

  • Додані описові повідомлення про помилки, коли потрібний Google API, але не завантажений
  • Додано "Я згоден" переклад на німецькі файли
  • Додано getPluginScripts у модуль Scriptloader
  • JQuery 3.x готова сумісність документа
  • Змінено wpgmza_google_api_status для передачі через wp_localize_script для запобігання перенаправлення в деяких випадках
  • Запобігається адресу електронної пошти UGM, яка передається в WPGMZA_localized_data
  • Вилучено надмірне розташуванняВиберіть спадне меню

7.10.33 :- 2018-09-05 :- Medium priority

  • Фіксований OpenLayers InfoWindow не відкривається

7.10.32 :- 2018-08-31 :- Medium priority

  • Виправлено надмірне налаштування wpgmza_gdpr_enabled, що призведе до помилки "згоди користувача, що не надається"

7.10.31 :- 2018-08-30 :- Medium priority

  • Виправлено рівень масштабування NaN, який змушує Карти Google зависати

= 7.10.30: – 2018-08-29: – Середній пріоритет * Виправлено "Доступ до незадекларованого статичного властивості" в деяких версіях PHP * Виправлено google-maps-api-error-dialog.html.php не існує

7.10.29 :- 2018-08-28 :- Medium priority

  • Покращена функція return_polygon_array, що робить багатокутну сторінку редагування більш надійною
  • Покращено GoogleAPIErrorHandler, модальне діалогове вікно з посиланнями на документацію тепер відображається на задній панелі та інтерфейс для адміністраторів
  • Впроваджено setOptions для загального маркерного модуля та модуля WPGMZA.GoogleMarker
  • Додано load_textdomain_mofile для виправлення проблем з перекладом
  • Додана подія storelocatorgeocodeccomplete (рідний) і storelocatorgeocodecomplete.wpgmza
  • Додана подія storelocatorresult (рідний) і storelocatorresult.wpgmza
  • Виправлено елементи керування картами не застосовуються без перемикання режиму розробника
  • Виправлено білий кордон навколо нового логотипа Google
  • Виправлено створення інформаційного вікна для блокування змін API керування Google API
  • Виправлено деякі глобальні налаштування, які не дотримуються (елементи керування масштабуванням тощо).
  • Виправлено неможливо змінити wpgmza_maps_engine у ​​WPGMZA_OTHER_SETTINGS, коли встановлено двигун
  • Вилучено суфіксовані події .wpgmza, які явно надсилаються, WPGMZA.EventDispatcher відправляє їх автоматично

7.10.28 :- 2018-08-20 :- Low priority

  • Виправлено двигун, який переключається на OpenLayers після збереження налаштувань на новій установці
  • Додано CSS виправлення для останніх змін інтерфейсу користувача Google для MacOS / iOS + Safari

7.10.27 :- 2018-08-17 :- Low priority

  • Додано фільтр wpgmza_xml_cache_generated
  • Додано дію wpgmza_xml_cache_saved
  • Покращена функція return_polyline_array, що робить редагування багатосторінкової сторінки більш надійною
  • Виправлено завантаження Google API до того, як буде надано згоду, якщо встановлено прапорець "Потрібна згода перед завантаженням"

7.10.26 :- 2018-08-15 :- Low priority

  • Покращена обробка помилок Google API після завершення роботи, модуль видає більш комплексне сповіщення
  • GoogleAPIErrorHandler перейшов до /js/v8/google-api-error-handler.js
  • Додано CSS виправлення для останніх змін інтерфейсу користувача Google (кнопки у трьох примірниках)

7.10.25 :- 2018-08-10 :- Low priority

  • Виправлено повідомлення "Невизначена змінна"

7.10.24 :- 2018-07-31 :- Low Priority

  • Доданий зворотний виклик regex для автозавантажувача класу для установок, де token_get_all недоступний
  • Додано префікс просторової функції до функції міграції просторових даних
  • Додано властивості LAT і LNG для результату GoogleGeocoder (для сумісності Pro 5 і UGM)
  • Змінено модуль Map для десеріалізації інших налаштувань та об'єднання в об'єкт налаштування карти
  • Змінено батьківський :: to \ Exception :: у parser селектора CSS
  • Виправлено виявлення версій для MySQL 8

7.10.23 :- 2018-07-23 :- Medium priority

  • Виправлена ​​помилка кінцевої точки API REST API для встановлення в підпапках
  • Додана версія PHP 5.3 версії readme.txt

7.10.22 :- 2018-07-18 :- Medium priority

  • Додано фільтр wpgmza_localized_strings
  • Додано початок API REST
  • Додана анімація прокрутки, коли натискається редагування маркера
  • Фіксовані символи UTF-8 не декодуються в нативну кодування PHP, перш ніж передавати їх для завантаженняHTML в модуль відповідності GDPR.
  • Фіксована кнопка маркеру редагування не активована після невдалого геокоду

7.10.21 :- 2018-07-09 :- Medium priority

  • Додана версія версії MySQL перевірена і опущена префікси функції ST_ для версій <8.0
  • Виправлені маркери не відображаються на передньому і задньому кінцях таблиць маркеру для серверів, що працюють зі старими версіями MySQL

7.10.20 :- 2018-07-05 :- Low priority

  • Додано гачок для нового вмісту вкладки GDPR
  • Додано JavaScript для елементів керування VGM GDPR
  • Виправлено WPGMZA \ DOMDocument :: saveInnerBody не зберігає текстові вузли

7.10.19 – 2018-07-05 :- Medium Priority

  • Додана нова подія "userlocationfound" відправлена ​​з WPGMZA.events
  • Додано повернутися назад, щоб перетворити UTF-8 на об'єкти HTML у установках без наявності багатобайтових функцій
  • Змінено інтерфейс налаштування GDPR, видалено резервне налаштування відповідності, додано повідомлення про затримку
  • Фіксований атрибут media = "1" не перевіряється
  • Фіксований геокодер нумерації не дає очікуваної відповіді на зворотний виклик
  • Виправлено модуль ScriptLoader, який завжди замальовує FontAwesome 4. *
  • Виправлена ​​помилка коду, що порушує WP Migrate DB integration
  • Виправлено спеціальні поля порожнім у списку маркера
  • Замінено застарілі функції MySQL зі функціями ST_
  • Замінено застарілий jQuery (вікно) .load функцій
  • Видалено автозавершення Google при використанні OpenLayers
  • Видалений протокол з значків маркера / фіксованих значків маркера зникає після переходу на https: //

7.10.18 – 2018-07-02 :- Medium Priority

  • Виправлено попередження про зворотній кінець GDPR, яке з'являється, коли дотримано GDPR

7.10.17 – 2018-06-29 :- Medium Priority

  • Виправлено обмеження на країну в магазині
  • Додано попередження GDPR адміністратора, що відхиляється, коли відповідність GDPR була вимкнена
  • Виправлено налаштування GDPR за замовчуванням на деяких установках

7.10.16 – 2018-06-21 :- Medium priority

  • Виправлено глобальні налаштування втрачено
  • Виправлено пробіл, який співпадає з змінною версії

7.10.15 – 2018-06-14 :- Medium priority

  • Фіксоване повідомлення про згоду GDPR пропущено, коли "запобігання іншим плагінам та темі, що зачіпає карти API" не встановлено

7.10.14 – 2018-06-14 :- Medium priority

  • Виправлено несумісність з UGM

7.10.13 – 2018-06-13 :- Low priority

  • Виправлено неможливо зберегти сучасний магазин
  • Фіксований скидання локатора магазину не працює
  • Виправлено вимкнення елементів керування карти, які не працюють
  • Фіксований перемикач локатора магазину

7.10.12 – 2018-06-12 :- Low priority

  • Вручений FontAwesome завантаження модуля ScriptLoader
  • Неприйнятна глобальна функція wpgmza_enqueue_fontawesome
  • Фіксовані кола та прямокутники працюють лише на карті ID 1

7.10.11 – 2018-06-08 :- Low priority

  • Виправлена ​​помилка JS при передачі несторінкового значення document.write
  • Тимчасове вирішення проблеми "Неочікуваний токен% у JSON"
  • API-згода більше не потрібна на зворотному шляху

7.10.10 – 2018-06-01 :- Medium Priority

  • Додавання параметра "Запобігання іншим плагінам та API завантаження тем"

7.10.09 – 2018-06-01 :- Medium Priority

  • Виправлено неперевершений попереджувальний коментар
  • Виправлена ​​сторінка для редагування карти, яка автоматично завершує роботу Google, коли для двигуна встановлено OpenLayers
  • Виправлена ​​іконка не перетягується на сторінці розташування редагування маркера

7.10.08 – 2018-05-31 :- Medium Priority

  • Виправлено неможливо змінити маркер в основному

7.10.07 – 2018-05-31 :- Medium Priority

  • Виправлена ​​проблема, коли двигун карти змінювався на зворотному боці

7.10.06 – 2018-05-31 :- Medium Priority

  • Додано "вимагати згоди до завантаження API" до налаштувань GDPR

7.10.05 – 2018-05-30 :- Low Priority

  • Виправлено використання $ цей, коли не в контексті об'єкта при використанні старої версії PHP
  • Виправлено Google іноді не визначено, коли обраний движок – OpenLayers

7.10.04 – 2018-05-30 :- Medium Priority

  • Виправлені координати відповіді геокоду не правильно інтерпретовані
  • Італійський переклад оновлений

7.10.03 – 2018-05-30 :- High Priority

  • Фіксований InfoWindow не відкривається, коли встановлено максимальну ширину
  • Виправлено $ це не в закритому контексті під час використання старих версій PHP
  • Виправлено налаштування кластерного додавання для Gold
  • Змінено діалогове вікно вибору двигуна карти

7.10.02 – 2018-05-29

  • Потужність двигуна за замовчуванням на Картах Google

7.10.01 – 2018-05-29

  • Виправлено невизначене індексне повідомлення в модулі GDPR

7.10.00 – 2018-05-25

  • Додано нові модулі Javascript
  • Додано нові PHP модулі
  • Клас AutoLoading реалізований
  • OpenLayers / OpenStreetMap інтеграція
  • Фіксована позиція Редагування маркера не працює з Pro 6. *
  • Виправлено кілька рядків, які не перекладені німецькою мовою
  • JS Minification
  • Додано "Режим розробника"

7.0.04 – 2018-05-07

  • Виправлена ​​інформація про PHP щодо радіуса за замовчуванням локатора магазину

7.0.03 – 2018-04-20

  • Покращена функція міграції просторових даних буде більш надійною
  • Виправлено невизначений індекс use_fontawesome

7.0.02 – 2018-04-15

  • Додана можливість вибору FontAwesome версії
  • Виправлена ​​помилка з масивом даних кола

7.0.01 – 2018-04-11 – Medium Priority

  • Переключено на WebFont / CSS FontAwesome 5 з міркувань сумісності
  • Виправлена ​​помилка JS для … у циклі при додаванні методів прототипу Array
  • Виправлено FontAwesome CSS як сценарій
  • Додана функціональність, щоб відповідати карті границям при редагуванні форм

7.0.00 – 2018-04-04

  • Додано довільне керування радіусом до Maps -> Settings -> Store Locator
  • Додано сучасний зовнішній вигляд магазину
  • Додано сучасний радіус локатора магазину
  • Додано спеціальне поле JS у Картах -> Налаштування -> Додатково
  • Додано просторові типи до таблиці маркеру
  • Додано Google API Error обробника та оповіщення
  • Додано код для відображення спеціальних полів у інфо-вікні, коли встановлено Pro
  • Свіжо встановити "Моя перша карта" за умовчанням для сучасного локатора магазину та радіуса
  • Розслаблений аналіз даних теми
  • Відключена функція перегляду вулиць, елементи керування масштабуваннями, елементи керування панорами та елементи керування на карті під час свіжих встановлень

6.4.08 – 2018-01-14 – Medium priority

  • Оновіть версії API Карт Google до версій 3.30 та 3.31
  • Після першої інсталяції користувачі тепер переходять на сторінку вітання
  • Оновлені автори
  • Оновлена ​​сторінка кредитів
  • Виправлена ​​несправна підтримка
  • Отримані речі готові до нової версії 7, яка на своєму шляху

6.4.07 – 2018-01-08 – Low priority

  • Додано обстеження дезактивації, щоб дізнатися, перш ніж перейти до версії 7
  • Перевірено на WP 4.9.1

6.4.06 – 2017-09-07 – Medium Priority

  • Виправлено помилку: рівень збереження не дотримується

6.4.05 – 2017-06-13 – Medium priority

  • Виправлена ​​помилка, яка призвела до появи помилок JS у редакторі карти
  • Виправлена ​​помилка, яка спричинила помилку XML-файлу (для маркерів) при спробі додати маркер у бекенда
  • Дозволені користувачі сховають функцію підписки на сторінці додатків
  • Нова функція: маркери масового видалення
  • Автозаповнення тепер працює при додаванні маркерів
  • Автозаповнення тепер працює на локаторі магазину на передній панелі
  • Виправлено помилку, яка змусила карту не завантажуватись у редактор карти для нових установок

6.4.04 – 2017-06-08 – Low priority

  • Перевірена на WordPress 4.8

6.4.03 – 2017-02-17 – Low priority

  • Додано можливість для партнерів використовувати свої партнерські посвідчення в про-посиланнях
  • Додана краща підтримка SSL
  • Додана підтримка короткого коду для файлів маркерів XML

6.4.02 – 2017-01-20 – Low priority

  • Вилучено ехо, яке було неправильно розміщено

6.4.01 – 2017-01-20 – Low priority

  • Додана можливість для користувачів підписатися на наш список розсилки

6.4.00 – 2017-01-11 – Medium priority

  • Додана опція встановлення адреси локатора для магазину за замовчуванням
  • Функціональність карти на весь екран додана
  • Виправлена ​​помилка, яка призвела до неправильного уникнення користувацького CSS
  • Виправлена ​​помилка, яка призвела до того, що кнопка "Зберегти маркер" не повертається, якщо адреса не може бути геокодирована
  • Додано додавання кешування, щоб сповістити користувачів про очищення кешу, коли маркер додано або відредаговано, або коли змінюються параметри карти
  • Естонська переклад додано
  • Виправлено помилкове налаштування мови за допомогою API Карт Google
  • Виправлена ​​помилка, яка викликала завантаження таблиці стилів адміністратора на всі сторінки адміністратора
  • Додана можливість змінювати вхід жесту
  • Виправлена ​​помилка, яка викликала попередження PHP, коли полігон або полілінія не мали polidata
  • Виправлено помилку, яка спричиняє невдалу вставку маркера за допомогою символів не-utf8 в адресі
  • Задокументовано всі функції PHP

6.3.20 – 2016-09-27

  • Виправлено великий розмір, який перешкоджав завантаженню карти у віджеті
  • Рефакторинговий код, який використовується для завантаження файлів Google Maps API і Script

6.3.19 – 2016-09-21

  • Виправлена ​​помилка, яка змусила деякі карти не завантажувати маркери під час завантаження сторінки

6.3.18 – 2016-09-15

  • Китайська підтримка – коли ваша мова налаштована на китайську (ZN_cn), карта буде завантажена з maps.google.cn
  • Івритський код мови виправлено при доступі до API Google Maps на івриті
  • Додана підтримка шару KML для видимості при додаванні / редагуванні багатокутників або поліліній
  • Виправлена ​​помилка з локатором магазину, який не використовує милі, якщо вибрано
  • Переміщено до версій 3.25 та 3.26 JavaScript API Google Maps
  • Дані даних оновлено
  • Коли маркер видалено, вид не знімається
  • Користувач javascript був перенесений у файл JavaScript
  • В даний час включена мінімізована та неперевершена версія JS-файлу на стороні користувача – мінімальна версія використовується за замовчуванням
  • Тепер ви можете встановити масштаб масштабу Google за допомогою короткого коду. Приклад: [wpgmza id = '1' zoom = 8]
  • Виправлено попередження PHP на сторінці журналу помилок

6.3.17 – 2016-08-07 – Medium priority

  • Користувачам додано тимчасову API-інтерфейс JavaScript для Google Maps, що не впливає негативно на UX на першу спробу користувача використовувати плагін.
  • Додано чек до передньої частини, щоб відображати карту, лише якщо є збережена ключ API JavaScript для Google Maps
  • Виправлені помилки, які викликали попередження PHP у магазині
  • Удосконалення UX на сторінці вітання
  • Виправлена ​​помилка, що спричинила помилку JS в результаті попередніх версій нової підтримки вкладки

6.3.16 – 2016-08-02 – Low priority

  • Клавіша API тепер використовується на сторінці редагування полілінії
  • Видалено скрипт зміни розміру, який призвів до того, що карта мерехтить на мобільних пристроях
  • Додана додаткова підтримка вкладки (tri-tabs-nav span)
  • Виправлена ​​помилка в списку обмежень для локаторів магазину

6.3.15 – 2016-07-31 – High priority

  • Патчі безпеки
  • Рефакторинг коду

6.3.14 – 2016-07-13 – High priority

  • Багато патчів безпеки – дякую вам Жерар Аралл
  • Виправлена ​​помилка – обрізати пробіл раніше, а потім – API ключа Google Maps API
  • Додаткова підтримка вкладки додана
  • Виправлена ​​помилка PHP

6.3.13 – 2016-07-07 – Medium priority

  • Додано переглянутий сценарій обробки API Карт
  • Видалити сценарій видалення стилю, оскільки це спричиняло конфлікти інтерфейсу користувача
  • Додана опція відключити API Карт від завантаження на передній край

6.3.12 – 2016-06-27 – Medium priority

  • Змінено сповіщення клавіші API, щоб зробити його простішим та інтуїтивним

6.3.11 – 2016-06-24 – Medium Priority

  • Невелика помилка активації виправлена
  • всі полігони та полілінії тепер доступні для перегляду при редагуванні або створенні нового полігону або полілінії
  • Повідомлення про вимоги до API ключових слів Google Maps

6.3.10 – 2016-05-03 – Low priority

  • Додано слухачів подій як для jQuery, так і для гармошів, так що карта може правильно ініціювати, якщо вона розміщена на вкладці або гармошці
  • Додано перевірки, щоб зупинити теми та плагіни з завантаження API Карт Google над нашим дзвінком на API на сторінках, що містять короткий код карти
  • Виправлено проблему SSL з маркерною URL-адресою (дякую Девіду Клау)
  • Виправлена ​​помилка, яка призвела до завантаження файлу CSS на всі передні сторінки
  • Додана підтримка SSL для файлу jQuery CDN

6.3.09 – 2016-04-15 – High priority

  • Скориговані Google Maps api 3.14 та 3.15, додано 3.23 та 3.24

6.3.08 – 2016-04-14 – Medium Priority

  • Забезпечує обхідний шлях для користувачів, які відчувають проблеми з завантаженням їх карток після оновлення до WordPress 4.5

6.0.07 – 2016-04-13 – Low Priority

  • Перевірена на WordPress 4.5
  • Тепер ви можете використовувати власний ключ API Google Maps для своїх карт

6.3.06 – 2016-04-04 – Low priority

  • Індонезійський переклад додано – спасибі Нено
  • Шведська переклади додано – Спасибі Мартіну Сліпнеру
  • Болгарська переклади додано – Спасибі Любомиру Колеву
  • Датчик API Google Maps вилучено з виклику API

6.3.05 – 2016-01-14 – Low priority

  • Додана сумісна сумісна вкладка

6.3.04 – 2016-01-04 – Low priority

  • Перевірено WP 4.4

6.3.03 – 2015-11-19 – Medium Priority

  • Виправлена ​​помилка, яка призвела до того, що карта не відображатиметься, якщо тема не вибрана

6.3.02 – 2015-11-06 – Low priority

  • Створено нову тематичну директорію – це дозволяє використовувати будь-яку тему або стиль карти, які ви хочете просто скопіювати та вставити його дані

6.3.01 – 2015-10-06 – Low priority

  • Додано 3 нових карт google для власних тем
  • Виправлена ​​інтернаціоналізація
  • iPhone карта маркер стиль виправити
  • Виправлено помилку автозаповнення
  • Всі мовні файли WP Google Maps були оновлені

6.3.0 – 2015-09-04 – Low priority

  • Додано 5 тем для мап до редактора мап
  • Додано вітчизняний візит картки, щоб ви могли перетягнути свої карти до області віджетів
  • Виправлено незначні помилки
  • Усі мовні файли оновлено

6.2.3 – 2015-08-20 – High priority

  • Включена остання версія даних, щоб виправити помилку, яка зазнала нової версії jQuery у WordPress 4.3
  • Оновлені datatables.responsive до 1.0.7 і містять мінфіковану версію файлу замість
  • Виправлено декілька помилок стилізації у редакторі карти
  • WP Google Maps тестувалась з WordPress 4.3

6.2.2 – Security Update – 2015-07-27 – High Priority

  • Патч безпеки
  • Перевірено WP 4.2.3

6.2.1 – Security Update – 2015-07-13 – High Priority

  • Покращення безпеки на сторінці редактора карти, карту JavaScript, категорії маркерів та коди інтерфейсу

6.2.0 – Liberty Update – 2015-06-24 – Medium Priority

  • Покращення безпеки (редактор карт, місцезнаходження маркерів, налаштування карти).
  • Погода була вилучена (не підтримується Картами Google)
  • Основна помилка виправлення (Google Map поміщає помилку) – змусило маркери карти не показувати, якщо локатор магазину карти не був включений
  • Виправлена ​​помилка, яка призвела до відображення повідомлення про помилку jQuery br

6.1.10 – 2015-06-10 – High priority

  • Патч безпеки XSS
  • Покращення безпеки
  • Виправлено помилку, яка не дозволяє вам додати маркер карти, якщо маркерів не було

6.1.9 – 2015-06-01 – Low priority

  • Французька помилка перекладу виправлена

6.1.8 – 2015-05-27 – Low priority

  • Грецький переклад додається – дякую Konstantinos Koukoulakis
  • Додана функція автоматичного завершення Карт Google до розділу "Маркер доповнення" редактора карт
  • Додано функцію автоматичного завершення Карт Google у Locator Locator

6.1.7 – 2015-04-22 – Low priority

  • Виправлено помилку json_encode (додатковий параметр) для хостів, що використовують версію PHP <5.3
  • Плагін перевірено на 4.2RC3

6.1.6 – 2015-04-17 – Low priority

  • Виправлено RocketsScript
  • Голландський переклад додано
  • Основний файл перекладу оновлено

6.1.5 – 2015-03-16 – High priority

  • Timthumb вилучено
  • Нова сторінка підтримки додана
  • Тепер ви можете обмежити пошук свого локатора в певній країні
  • Виправлено помилку у редакторі карти
  • Виправити помилку SSL
  • Підвищення юзабіліті при натисканні правою кнопкою миші, щоб додати маркер на карті.
  • Додано переклад російською, литовською та португальською мовами

6.1.4 2015-02-13 Medium priority

  • Виправлено помилку Safari
  • Виправлена ​​проблема з маркерів карти, що містять адреси з окремими лапками
  • Тепер ви можете встановити макс зум вашої карті Google
  • Переклад файл оновлено

6.1.3 2015-01-29 Medium priority

  • Виправлено помилку сервера IIS
  • Маленькі виправлення помилок карти
  • Бразильський португальський файл мови оновлено
  • Виправлено помилку активації

6.1.2 2015-01-19 Low priority

  • Покращення коду (попередження PHP)
  • Нові мови додані
  • Не тестовано з активною версією WooCommerce

6.1.1 2014-12-19 Low priority

  • Оновлення перекладу файлів
  • Покращення коду

6.1.0 2014-12-17 Medium priority

  • Додано альтернативний метод для вилучення даних маркера

6.0.31 2014-11-28 Low priority

  • Виправлена ​​помилка категорії

6.0.30 2014-11-26

  • Додана перевірка класу DOMDocument при створенні файлів даних маркерів карти
  • Видалено попередження про кеш об'єкта APC
  • Додано нові рядки до PO-файлу

6.0.29 2014-11-04

  • Нова опція: тепер ви можете показати або сховати піктограму зі стрілкою у магазині
  • Нова функція: додавання користувальницького CSS на сторінці налаштувань
  • Покращення коду

6.0.28 2014-10-22

  • Конфлікт конфлікту "Enfold / Avia" вирішено (API Google Maps завантажується двічі)
  • Кращий контроль файлів / каталогів маркерів
  • Італійський переклад додано (Tommaso Mori)

6.0.27 2014-09-29

  • Французький переклад оновлений Arnaud Thomas
  • Оновлення безпеки (спасибі www.htbridge.com)
  • Покращення коду (попередження PHP)
  • Виправлено помилку "Google Map Store Locator" – масштаби масштабування карти на 300 км, 150 км та 75 км були невірними

6.0.26 2014-08-22

  • Спроба виправити помилки "is_dir" і "open_basedir" деякі користувачі зазнають.
  • Оновлено timthumb до версії 2.8.14

6.0.25 2014-08-13

  • Вилучено використання "is_dir", що спричинило фатальні помилки в деяких хостах

6.0.24 2014-07-31

  • Додана додаткова підтримка для керування папками та звітування про помилки
  • Покращення коду (попередження PHP)
  • Краще полігон і полілінія обробки
  • Еврейський переклад додано – спасибі Галу Дотану

6.0.23 2014-07-30

  • Додана додаткова підтримка пошкодженої полілінії та багатокутника даних – Низьке пріоритетне оновлення

6.0.22 2014-07-25

  • Виправлено неправильне попередження про дозволи, коли дозволи "2755" та ін.
  • Додайте класи до елементів локації магазину магазинів Google

6.0.21

  • Ультрафіолетовий інтерфейс
  • Тепер ви можете клацнути правою кнопкою миші, щоб додати маркер до карти
  • Нові маркери карти можна перетягувати
  • Полігони та полілінії тепер мають мітки
  • Невеликі виправлення помилок

6.0.20

  • Тепер ви можете змінити рядок запиту для локатора магазину

6.0.19

  • Виправлена ​​помилка, яка призвела до відтворення файлу маркера на кожному завантаженні сторінки в деяких випадках.
  • Виправлено помилку виводу списку маркера (iPhone)
  • Тепер показуються параметри за замовчуванням для шляху маркерів та URL-адреси
  • Вилучено помилку "Картка Google не вдалося завантажити"
  • Виправлена ​​помилка, яка при знятті GPS координує при додаванні lat, ng як адресу

6.0.18

  • Тепер ви можете вибрати, які ролі можуть отримати доступ до редактора карт

6.0.17

  • Невелике оновлення: PO-файли оновлені

6.0.16

  • Тепер ви можете вибрати, в яку папку будуть збережені маркери
  • Покращена звітність про помилки для файлів

6.0.15

  • Невеликі виправлення помилок
  • Виправлено помилку місця розташування маркеру карти
  • Переклад на російську мову додано Борисою Джарашкович

6.0.14

  • Покращення коду
  • Додано опцію вибору Celsius або Fahrenheit з погодним шаром Карт Google

6.0.13

  • Виправлено попередження PHP, і плагін тепер сумісний з PHP 5.5

6.0.12

  • Виправлено помилку місця розташування маркера google map

6.0.11

  • Невелика помилка виправлена ​​на сторінці вітання WP Google Maps

6.0.10

  • Перевірено на WP 3.9
  • Виправлена ​​помилка, яка відображає лише дві категорії маркерів карти для локатора магазину (pro)
  • Додано можливість вибрати версію API Google Map, яку ви хочете використовувати. Виникли проблеми при використанні Google Map API v3.15 (лінії були створені на карті з будь-якої причини за замовчуванням – це Google Map API V3.14)

6.0.9

  • Карти тепер автоматично працюють у вкладках, не додаючи жодного коду
  • Додано повзунок "масштабування" до налаштувань карти Google
  • Додано чек для GoDaddy WordPress-хостингу та кешу об'єктів APC через проблеми, що виникають при його використанні
  • Виправлено помилку полілінії
  • Додано параметри "непрозорості обведення" до полігонів
  • Додано попередження, коли користувачі хочуть використовувати% для висоти карти

6.0.8

  • Виправлено помилку стилю Mac Firefox за допомогою WP Locator Locator Google Maps Store
  • Виправлена ​​помилка функції в файлі функцій полілінії

6.0.7

  • Оновлення плагіна тепер обробляється правильно

6.0.6

  • Багатокористувацькі виправлення помилок
  • Виправлено помилку помилки файлу маркеру XML (спасибі Endymion00)

6.0.5

  • Маркери тепер зберігаються у папці завантажень
  • Невеликі виправлення помилок

6.0.4

  • Оновлення продуктивності

6.0.3

  • Невелика помилка виправлена

6.0.2

  • Виправлена ​​помилка стилю

6.0.1

  • Невелика помилка виправлена

6.0.0

  • Виправлено помилку ширини карти з макетом даних. Тепер падає у відповідність із шириною карти.
  • Додано додаткові параметри на сторінку налаштувань карти
  • Виправлена ​​помилка, яка змусила новий геокод при кожному редагуванні маркера, навіть якщо адреса не була змінена
  • Оновлено TimThumb від 2.8.11 до 2.8.13
  • Тепер ви можете вибрати для своєї карту InfoWindows, щоб відкрити за допомогою миші або наведення курсора миші
  • Краща обробка помилок, коли карта не може відображатися через конфлікти або помилки JS
  • Виправлена ​​помилка, яка спричиняє високий рівень використання пам'яті
  • Основні виправлення помилок

5.24

  • Виправити помилку – стиль картини змінив стиль вашої теми.

5.23

  • Додайте анімацію до маркерів карти (lite)
  • Виберіть інфо-вікно відкрити за умовчанням (lite)
  • Додайте місце на велосипеді та трафік на карту (lite)
  • Суттєве покращення кодування та виправлення помилок

5.22

  • Виправлена ​​помилка сортування маркера

5.21

  • Виправлено помилку, що, якщо натискання кнопки "Додати творця" призвела до помилки, кнопка "додати маркер" зникне.

5.20

  • Категорії тепер можна приховати від списку маркерів
  • Німецький переклад додано завдяки Маттео Ендеру

5.19

  • Виправлена ​​помилка стилю з Firefox
  • Виправлено помилку, яка призвела до втрати всіх маркерів при оновленні

5.18

  • Додано вдосконалене стиль до адреси на інфо-карті карти

5.17

  • Виправлена ​​помилка оновлення

5.16

  • Плагін тепер перевіряє, чи вже завантажений API Карт Google, перш ніж спробувати завантажити його знову
  • Виправлено деякі помилки SSL

5.15

  • Додана функціональність маркерної категорії
  • Додано функцію Google Map Mashup
  • Виправлені дрібні помилки
  • Додана зворотна сумісність для старих версій WordPress
  • Замінено застарілі функції викликів функції WordPress
  • Додано іспанський переклад – Спасибі Фернандо!

5.14

  • Плагін карту тепер використовує новий медіа-менеджер
  • Виправлено деякі стильові конфлікти
  • Додано відсутні рядки до локалізації
  • Оновлено до останньої версії Timthumb

5.13

  • Виправлена ​​невелика помилка

5.12

  • Вилучено застарілий код

5.11

  • Додано виправлення помилок SSL
  • Виправлена ​​помилка, яка не дозволяє користувачам редагувати точне місце розташування

Щоб отримати докладнішу інформацію, перегляньте сайт WP на Картах Google